Won't run after adjusting graphics settings LINUX

Added by liamdawe almost 4 years ago

Hi guys, just downloaded the new version, I turned up some graphics settings and now the game refuses to run.

GLW_StartOpenGL() - could not load OpenGL subsystem: Missing GL version
See "/home/liam/.etlegacy/legacy/crashlog.txt" for details.

Here’s my log: http://pastebin.com/N9xsCDJW


Replies (12)

RE: Won't run after adjusting graphics settings LINUX - Added by Spyhawk almost 4 years ago

If it was running before, remove your profile and start again. Not sure what what would be the issue (if it was running before..)
You also don’t need the mp_bin.pk3 file in your etmain folder.

RE: Won't run after adjusting graphics settings LINUX - Added by liamdawe almost 4 years ago

Thanks, it seems if I enable AA it suddenly fails to find GL?

As for the "mp_bin.pk3" file, I used the installer, so I’ve no idea what files are needed/not needed.

RE: Won't run after adjusting graphics settings LINUX - Added by Spyhawk almost 4 years ago

liamdawe wrote:

Thanks, it seems if I enable AA it suddenly fails to find GL?

Might not be supported by your gfx card? Don’t really know to be honest.

As for the "mp_bin.pk3" file, I used the installer, so I’ve no idea what files are needed/not needed.

Thanks, I’ll have a look at our installer then.

RE: Won't run after adjusting graphics settings LINUX - Added by liamdawe almost 4 years ago

I have an Nvidia 970, I’m sure it’s supported

RE: Won't run after adjusting graphics settings LINUX - Added by Spyhawk almost 4 years ago

liamdawe wrote:

I have an Nvidia 970, I’m sure it’s supported

It depends on the driver too. If you’re using nouveau, you might have some trouble...

I cannot reproduce the issue with mp_bin.pk3. Both 32 and 64 bit installers don’t install it.

RE: Won't run after adjusting graphics settings LINUX - Added by liamdawe almost 4 years ago

I am on the official nvidia driver.

I just tested the 32bit installer, it also dumps mp_bin.pk3 in the etmain folder.

RE: Won't run after adjusting graphics settings LINUX - Added by Dragonji almost 4 years ago

Do you use ET Legacy installer or ET 2.60b installer? Do you have et.x86 file in your dir?

RE: Won't run after adjusting graphics settings LINUX - Added by liamdawe almost 4 years ago

I’m using the installer links from the download page for 2.74.

RE: Won't run after adjusting graphics settings LINUX - Added by Spyhawk almost 4 years ago

liamdawe wrote:

I’m using the installer links from the download page for 2.74.

Again, I cannot reproduce.

The installer would have installed them in fs_basepath. Your mp_bin is in fs_homepath, so you have got it from another source..
Please ensure you don’t mix homepath and basepath!

Edit: my bad, they are indeed in basepath. Still cannot reproduce.

RE: Won't run after adjusting graphics settings LINUX - Added by liamdawe almost 4 years ago

I literally have no idea what you’re talking about.

I ran the installers in the terminal, it downloaded the content for me.

RE: Won't run after adjusting graphics settings LINUX - Added by sadsfae over 3 years ago

I had this issue as well, the only workaround I found was to rename my etconfig.cfg and restart and NOT enable AA.

mv ~/.etlegacy/legacy/profiles/sadsfae/etconfig.cfg ~/.etlegacy/legacy/profiles/sadsfae/etconfig.cfg.OLD

AA seems to break on Nvidia cards, not sure why as all other games can use AA just fine (Urban Terror, GOG games, etc).

System Info:
——————
Fedora 22 x86_64 - Kernel 4.2.3-200.fc22.x86_64
nvidia-driver-355.11-3.fc22.x86_64
nvidia-driver-libs-355.11-3.fc22.x86_64
SDL2-2.0.3-5.fc22.x86_64
SDL-1.2.15-17.fc22.x86_64
xorg-x11-server-Xorg-1.17.3-1.fc22.x86_64
ETL 2.74 x86_64

I’ve updated my ET:L Linux installation/play blog post here:
http://hobo.house/2015/11/06/play-enemy-territory-legacy/

(1-12/12)