Compability with TrueCombat: CQB

Added by yks over 4 years ago

People at True Combat community are discussing about ET:L and Coroner experienced compability issues with ET:L.

Look at 2nd post:
http://www.truecombatelite.com/forums/viewtopic.php?f=48&t=2084&start=45

Could these issuses be fixed?

EDIT: Some of this discussion: http://www.truecombatelite.com/forums/viewtopic.php?f=45&t=2393&start=60


Replies (38)

RE: Compability with TrueCombat: CQB - Added by yks over 3 years ago

Some observations with 2.72 and CQB

Yourself[PL] wrote:

Works fine with cqb + bots but there is a problem with sound . Seems like sound looping script or something like that is still not >fixed [samples overlap] Someone did mention about this problem but i don’t remember who was that.
Second. Game is laggy, what does it mean? I feel like a 300ms ping player when i press fire , aiming button, reload button. Mouse >works fine FPS is stable but i get the weird impression. There are no problems with my keyboard or mouse, just etlegacy does >something strange with mouse/keyboard input. In stock et/cqb/tce those problems are not detected, only legacy has problems with it.

RE: Compability with TrueCombat: CQB - Added by illwieckz over 3 years ago

Hi, good news, there is some talks these days about a new and unlocked release of CQB targetting ET:Legacy and Coroner’s said it will work on it soon.

Do you have any idea about the sound issue Yourself_PL reported?

RE: Compability with TrueCombat: CQB - Added by Spyhawk over 3 years ago

Good, let’s see what happens!

No, I personally don’t have any idea about the sound issue (#834). It seems to happen only in CQB mod.

RE: Compability with TrueCombat: CQB - Added by Yourself_PL over 3 years ago

HI there. Few thoughts about that sound issue.
1 - I am convinced there is a weird micro LATENCY between mouse button and expected shots. As YKS did mention #834, stock et does not make any problem.
2- Looping.
While firing on full auto mode, samples overlap each other and it sounds very bad. At this moment i dont have installed ETL to make a short example of that issue but maybe today i will find some time to show you what i mean. It would be nice to fix it, before 2.73

RE: Compability with TrueCombat: CQB - Added by Yourself_PL almost 3 years ago

1. Fps drop is related with player models in my case.
http://s10.postimg.org/74ixxwra1/image.jpg
http://s10.postimg.org/6ga3eysk9/etl.jpg
I will change my autoexec to increase memory.
2. Sound issue is not fixed, is better than previous version but still not good enough as it is in the et. Simple sample:
If i die while reloading, sound of reloading is still audible. This thing does not happen with stock et. Samples still overlap each other.

All these problems occurs with latest cqb. I have no idea how legacy works itself. Anyway good job. I really love
#define ENTITY_LIGHT_STEPS 16

to

#define ENTITY_LIGHT_STEPS 64

RE: Compability with TrueCombat: CQB - Added by Spyhawk almost 3 years ago

Are you really sure that FPS drop is related to the models?

Also, could one of you provide me with that latest CQB? Even better if you get the Linux version (if it exists at all..).

Not sure I’ll be able to fix that sound issue properly once and for all (fixed one bug already, but that one is another unrelated bug), but I might at least try.

RE: Compability with TrueCombat: CQB - Added by Spyhawk almost 3 years ago

Isn’t there a standalone CQB 0.223 version somewhere? If it’s easier to install, I’d rather use that one.

RE: Compability with TrueCombat: CQB - Added by illwieckz almost 3 years ago

Spyhawk, you can use my pimi tool to get the latest cqb (just do “pimi.sh cqbtest”), since the TC/CQB packages are an incredibly overcomplicated mess and really painful to install the standard way (that kind of mess when it’s faster and safer to write a dedicated script than doing it by hand).

[Edit: pimi is linux-only, but it’s not an issue for you , it will download all required stuff even if it’s splitted in multiple archives and will perform a clean Linux installation (without stuff for other OS) in ~/.etlegacy (by default)]

[Edit²: the unofficial cqb_dim mod is known to be broken on Linux, that’s why pimi only support tce and cqb]

RE: Compability with TrueCombat: CQB - Added by Yourself_PL almost 3 years ago

Reply to me on the DevBoard Spyhawk.

RE: Compability with TrueCombat: CQB - Added by Spyhawk almost 3 years ago

@illwieck> Yeah, true. I was actually referring to the 0.224 version which isn’t public yet (not sure about what has changed since 0.223..).

1 2 (26-38/38)