Cannot join any server / create a server ("couldn't load official pak file")

Added by eeesprit over 5 years ago

Hello there,

I’m so happy to have found this version of ET that can be run under my Mac OS X 10.9.2... getting nostalgic!

I’m quite a noob in computer science, so here are few questions for you guys :
- I’ve got this ugly message when trying to connect to any server (after looking on the internet, I’ve tried some servers which seem to be compatible with ETL, such as FlA Clan or Team Muppet)
"Couldn`t load official pak file; verify your installation and make sure it has been updated to the latest version."
Is it because the server is finally not compatible with ELT? Or I am the problem?

- When I used to play, I remember having ETPro, creating some .cfg files etc. I’ve run ETL with the app launcher, but is there any folder for the game?! I’m pretty sure my precedent message error is relative to punkbuster or so...

- How to launch/read the console on a Mac? (I don’t have the "small 2" on my keyboard)

Thanks for your help, I really hope I soon will be able to play this awesome game again...

Thibault from France


Replies (9)

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by Radegast over 5 years ago

I am guessing that you found my OS X binary that I posted on SD forums? It is broken, sorry. You will have to wait for the next release.

I’ve run ETL with the app launcher, but is there any folder for the game?!

ET:L stores its files in ~/Library/Application Support/etlegacy

- How to launch/read the console on a Mac? (I don’t have the "small 2" on my keyboard)

Hold SHIFT + ESC

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by thunder about 5 years ago

cant connect to legacy server?
Running win7 professional 64 bit

bug.png (56.5 KB)

Bug

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by IR4T4 about 5 years ago

Ensure files 'pak0.pk3’, 'pak1.pk3’ and 'pak2.pk3’ are in etmain of fs_basepath.

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by thunder about 5 years ago

I have just installed full latest package.. Is there something else I need todo?

EDIT: and pak 0 and so is in legacy’s etmain folder...

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by thunder about 5 years ago

I copied and pasted the original paks from my wolfenstein folder and over to etlegacy’s etmain and now it works... Dont ask...

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by sadsfae about 4 years ago

I get this same error when trying to join a 2.60b / 1.27 NQ server on a fresh 2.74 install, any ideas what causes this and how to fix?

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by sadsfae about 4 years ago

sadsfae wrote:

I get this same error when trying to join a 2.60b / 1.27 NQ server on a fresh 2.74 install, any ideas what causes this and how to fix?

http://dev.etlegacy.com/projects/etlegacy/wiki/FAQ#Can-I-install-ET-Legacy-alongside-the-original-Wolfenstein-Enemy-Territory-installation

FAQ states I can have both older ET and ET:L live alongside each other, does this mean I can just copy the .pk3 files over or install into same target location (assuming file names are different?). Would this be the recommended thing to do? It’s not clear to me if it means the same target path (so it would fix the can’t load pak error) or if you mean two separate installations.

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by RaFaL about 4 years ago

Just copy pak’s file to etmain directory inside your etl instalation

RE: Cannot join any server / create a server ("couldn't load official pak file") - Added by jemstar about 4 years ago

oops response not related to MAC,

Delete or ignore!

(1-9/9)