ETL crashes/no sound while changing sound device

Added by kajto3 4 months ago

Hello. I’m using an usb sound card that tends to disconnect and break the sound (some cable or usb port issue). Unplugging and plugging in the card brings back the sound, the default sound device is automatically updated etc. But not for ETL. After unplugging and plugging in again there is no sound in ETL. Other games usually can handle that and can bring back the sound. While playing regular ET snd_restart usually helped with such issues. But after trying to snd_restart in ETL while the sound is lost, ETL crashes. Sometimes happens even while exiting ETL after sound is lost. It freezes and just says it’s not responding, no errors. Also no crash dialog while starting ETL after this crash.

Basically, in some cases ETL fails to update the sound device while it’s changed in Windows (due to sudden sound interruption like unplugging the cable) and the only option is restarting ETL.
I’ve made some tests though. I have 2 sound devices - integrated Realtek HD Audio (speakers) and external Audiotrak Maya U5 (headphones).

1. Loading ETL with Maya, sound coming from headphones, manually changing the default sound device in Windows to Realtek, snd_restart, now the sound is played from laptop’s speakers (wow it works)
2. Loading ETL with Maya again. Unplugging the card cable. There is no sound in ETL. The default device in the system has changed automatically to integrated Realtek since it’s now the only one. Plugging cable in again - still no sound in ETL from any device, the sound in Windows working perfectly fine. snd_restart into console = crash.
3. Loading ETL with Realtek and cable unplugged. Plugging in - the sound is still playing from the speakers, but the default device has changed to Maya and the sound in Windows is playing from headphones. snd_restart fixes it this time and now ETL is playing sound via Maya.

s_device is set to default -1. Does -1 mean ETL will change the device automatically? I’ve tried setting it to 0, as it represents Maya while checking the sndlist, doesn’t seem to change anything.

I’m running 2.75 version from this site on Windows 10, always running as admin. I’m gonna comment it after the ETL update. I also realise it doesn’t have to be ETL bug and probably I should fix my card or something, but I believe you can do something to help and maybe it helps someone else.


Replies (3)

RE: ETL crashes/no sound while changing sound device - Added by Spyhawk 4 months ago

Sound input is managed by the underlaying SDL library. We’re shipping the next release with the latest SDL update, so you’ll see if it improves the issue.
In any case, you’d better file the issue on the SDL tracker, as we don’t manage sound device directly in our own code.

RE: ETL crashes/no sound while changing sound device - Added by kajto3 3 months ago

New update fixed the issue!

RE: ETL crashes/no sound while changing sound device - Added by Spyhawk 3 months ago

We’re glad to hear that. Enjoy!

(1-3/3)