Bug #1015

Something is wrong in code regarding specular renderer2

Added by thunder over 2 years ago. Updated over 1 year ago.

Status:Fixed% Done:

100%

Priority:NormalSpent time:-
Assignee:thunder
Category:General
Target version:renderer2
OS: Arch:

Description

specular is fine at some angles but not with other angles, and seems worse when you are 90’ to a texture...
also lot of models seems too spec even tho the spec is that "white"..

etlegacy-2017-02-26-171229-fueldump.jpg (352 KB) thunder, 03.03.2017 21:46

etlegacy-2017-02-26-182907-radar.jpg (364 KB) thunder, 03.03.2017 21:47

etlegacy-2017-02-26-182916-radar.jpg (343 KB) thunder, 03.03.2017 21:47

etlegacy-2017-03-09-185615-radar.jpg (399 KB) thunder, 09.03.2017 18:59

etlegacy-2017-05-07-130731-battery.jpg (241 KB) thunder, 07.05.2017 13:10

731
732
733
739
752

Associated revisions

Revision eb5fa0e7
Added by IR4T4 over 1 year ago

renderer2: fix specular glitch refs #1015

History

#1 Updated by thunder over 2 years ago

okey, more wierdness.. I comented out spec texture on camo mesh used on Radar, but it’s still specular silver see image.

#2 Updated by thunder over 2 years ago

more info on this subject:

it seems there is some link to our spec problems connected with transperancy if that may help out..

#5 Updated by thunder over 2 years ago

  • Assignee deleted (Jacker)

Been swirling around in there and it seems that this issue is on certain brushes, and most time it is textures without shaders WHEN the map was compiled. now we have shaders on everything because of normal and specmaps.
Even if I try with other shader or no shader the result is still the same it seems.
So it is something with the worldbrushes.
Also it seems that some models are too bright, but that may be my textures.
I dont know if the "construction crates" have something that does them brighter ingame to easier find them or something..
for me R2 is just a big mess really..
But I will drag in all info I can along the way so that someone with knowledge maybe can fix it.

#6 Updated by thunder over 2 years ago

good news, it seems I am able to fix this with a bit more advanced shaders

#7 Updated by thunder over 2 years ago

  • Assignee set to thunder

#8 Updated by thunder over 2 years ago

shader issue

#9 Updated by IR4T4 over 2 years ago

  • Status changed from Fixed to Confirmed

#10 Updated by thunder about 2 years ago

@IR4T4 are you able to add light in generic shader then this is solved
this doesnt happend to new compiled maps whit new shaders..

#11 Updated by thunder about 2 years ago

no, I withdraw that Irata.. it isnt right

#12 Updated by IR4T4 over 1 year ago

I can’t reproduce this anymore (with r_materialscan 1,2 & 3).

So even if the game is using old shader definitions (r_materialscan 1) the issue is gone.

#13 Updated by IR4T4 over 1 year ago

  • Status changed from Confirmed to Feedback
  • % Done changed from 100 to 90

#14 Updated by IR4T4 over 1 year ago

  • Status changed from Feedback to Fixed
  • Priority changed from High to Normal
  • % Done changed from 90 to 100

Also available in: Atom PDF