Bug #1040

lua script doesnt work on a no quarter legacy server

Added by Niek almost 2 years ago. Updated about 1 year ago.

Status:Fixed% Done:

100%

Priority:Urgent
Assignee:IR4T4
Category:Lua scripts
Target version:-

Description

Got a problem with legacy and noquarter that we can’t get lua working.
Without legacy it works but not with.

Here is the logg

ET Legacy v2.75 linux-i386 Sep 13 2016
Zone megs: 64

———————-
9248 files in pk3 files
execing default.cfg
couldn’t exec autoexec.cfg
Hunk_Clear: reset the hunk ok
Not logging server attacks to disk.
Found high quality video and fast CPU
... DBMS is disabled
— Common Initialization Complete —

Network initialized.

—— Server Initialization ——
Server: bremen_truckmod
Hunk_Clear: reset the hunk ok
—– FS_Startup —–

———————-
9248 files in pk3 files
Sys_LoadDll(/game/et/niek/snipertest/nq/qagame.mp.i386.so)... failed: "liblua5.1.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/game/et/niek/snipertest/nq/qagame.mp.i386.so)... failed: "liblua5.1.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(nq/qagame) failed to load library
—– Server Shutdown —–
Resolving etmaster.idsoftware.com (IPv4)
etmaster.idsoftware.com resolved to 192.246.40.60:27950
Sending heartbeat to etmaster.idsoftware.com
Resolving master.gamespy.com:27900 (IPv4)
master.gamespy.com:27900 has no IPv4 address.
Couldn’t resolve address: master.gamespy.com:27900
Resolving master0.gamespy.com (IPv4)
master0.gamespy.com has no IPv4 address.
Couldn’t resolve address: master0.gamespy.com
Resolving clanservers.net (IPv4)
clanservers.net has no IPv4 address.
Couldn’t resolve address: clanservers.net
Resolving wolfmaster.idsoftware.com (IPv4)
wolfmaster.idsoftware.com resolved to 192.246.40.70:27950
Sending heartbeat to wolfmaster.idsoftware.com
—————————
SQLite3 can’t close db - not active.
VM_Create on game failed

History

#1 Updated by IR4T4 almost 2 years ago

Niek, did you just copy your old install? Is there a file 'liblua5.1.so’ in path?

The mod doesn’t start because of missing liblua.

#2 Updated by Niek almost 2 years ago

I tested the lua without legacy then it works but when starting it with etlded then it doesnt work.
Liblua5.1 is in also tried liblua 5.3
with etded it works

#3 Updated by IR4T4 almost 2 years ago

I can’t reproduce this issue. My local Linux 1.2.9b6 NQ test system works fine with Lua.

#4 Updated by thunder almost 2 years ago

think you have to put the liblua in right place, remember I had some problems with my etnam mod server too..

#5 Updated by Yop over 1 year ago

Hello,
I have the same problem with a vanilla install. ET:Legacy v2.75 and NQ v1.2.9
I followed that procedure : http://et.clan-etc.de/noquarter_wiki/wiki/no_quarter_mod.html#Installing_LUA
I checked this :
  • lua is lua-5.1.5_Linux26 g4_lib.tar.gz = ubuntu 32 bits (my server is a 32bits chroot on a Debian Jessie 64 bits)
  • liblua5.1.permissions are 755 but I tried 777 too without success
  • fs_basepath = . and fs_homepath = /home/yop/.etlegacy
  • I tried to copy liblua5.1 everywhere (even when it’s stupid) and got always the same result.
  • I tried to copy qagame.mp.i386.so everywhere (even when it’s stupid) and got always the same result.

Niek, did you find a solution ?

#6 Updated by thunder over 1 year ago

you’ve tried to put it inside nq folder?
also tried to put it where the executable of etl are?

#7 Updated by hellreturn over 1 year ago

Yop wrote:

Hello,
I have the same problem with a vanilla install. ET:Legacy v2.75 and NQ v1.2.9
I followed that procedure : http://et.clan-etc.de/noquarter_wiki/wiki/no_quarter_mod.html#Installing_LUA
I checked this :
  • lua is lua-5.1.5_Linux26 g4_lib.tar.gz = ubuntu 32 bits (my server is a 32bits chroot on a Debian Jessie 64 bits)
  • liblua5.1.permissions are 755 but I tried 777 too without success
  • fs_basepath = . and fs_homepath = /home/yop/.etlegacy
  • I tried to copy liblua5.1 everywhere (even when it’s stupid) and got always the same result.
  • I tried to copy qagame.mp.i386.so everywhere (even when it’s stupid) and got always the same result.

Niek, did you find a solution ?

Got same error while I upgrading to another machine -

apt-get install liblua5.1-0:i386

That fixed it for me. Also i have liblua5.1.so next to etlded. That resolved the issue for me. So posting here in case if that helps someone. LUA works fine for my NQ. Regards

#8 Updated by IR4T4 about 1 year ago

  • % Done changed from 0 to 100

#9 Updated by IR4T4 about 1 year ago

  • Status changed from New to Fixed

Also available in: Atom PDF