Bug #1058

renderer2: buildcubemaps command doesn't work

Added by thunder almost 2 years ago. Updated 9 months ago.

Status:Fixed% Done:

100%

Priority:LowSpent time:-
Assignee:-
Category:Client
Target version:renderer2
OS: Arch:

Description

comand buildcubemaps, doesnt work


Related issues

Related to ET: Legacy Development - Bug #552: renderer2: missing foliage support Fixed 01.08.2014

Associated revisions

Revision 13a0549a
Added by IR4T4 over 1 year ago

renderer2: fix R_BuildCubeMaps (reflective specular requires normal
mapping) refs #1058

History

#1 Updated by IR4T4 almost 2 years ago

  • Subject changed from buildcubemaps to buildcubemaps command doesn't work
  • Category changed from General to Client
  • Target version changed from ALL to renderer2

#2 Updated by IR4T4 almost 2 years ago

Map oasis:
Trying to select uncompileable shader permutation: 160 of shader "vertexLighting_DBS_entity"

See "/home/olaf/.etlegacy/legacy/crashlog.txt" for details.

#3 Updated by IR4T4 almost 2 years ago

  • Status changed from New to Confirmed

#4 Updated by IR4T4 over 1 year ago

  • Related to Bug #552: renderer2: missing foliage support added

#5 Updated by IR4T4 over 1 year ago

  • % Done changed from 0 to 40

Command itself should be fixed.

For some reasons there are many "GL_Bind: NULL image" prints on console while command execution which doesn’t occure when R_BuildCubeMap is called in tr_bsp/RE_LoadWorldMap on map load.

#6 Updated by IR4T4 about 1 year ago

  • % Done changed from 40 to 50

Cubemaps are now created at start when r_reflectionmapping 1 is set (0 by default).

Note: reflection mapping requires r_normalmapping 1.

#7 Updated by IR4T4 about 1 year ago

  • Subject changed from buildcubemaps command doesn't work to renderer2: buildcubemaps command doesn't work

#8 Updated by IR4T4 9 months ago

  • % Done changed from 50 to 100

#9 Updated by IR4T4 9 months ago

  • Status changed from Confirmed to Fixed

Fixed.

Also available in: Atom PDF