Bug #241

Sound and video not matching in demo when timescale is other than 1

Added by Saukko over 6 years ago. Updated almost 6 years ago.

Status:New% Done:

0%

Priority:NormalSpent time:-
Assignee:-
Category:Client
Target version:2.78
OS: Arch:

Description

So as the title says, when you for example slowdown the demo under 1 timescale, then the video and sound won’t be synced. I have a test demo which I just used to lower the timescale under 1. Slowing down the demo will also result in that the console will come down slower than used to.

demo0000.dm_84 - demo test (95.3 KB) Saukko, 07.03.2013 15:57


Related issues

Related to ET: Legacy Development - Bug #922: Fix timescale div 0 issues Feedback 14.03.2016

History

#1 Updated by Jacker over 6 years ago

The console speed is tied to the timescale, and when the demo is slowed down the console is also slowed down.. This is actually how it works on vanilla ET. Ill check the sync though.

#2 Updated by Saukko over 6 years ago

Jacker wrote:

The console speed is tied to the timescale, and when the demo is slowed down the console is also slowed down.. This is actually how it works on vanilla ET. Ill check the sync though.

Is it possible to untie the slowing console, because when we go to enough slow timescale, it takes forever for the console to come down?

#3 Updated by Jacker over 6 years ago

Well i need to check this out but i believe that to "untie" console from the effects of the timescale would be a large overhaul of the client source, but ill check what i can do.

#4 Updated by IR4T4 over 6 years ago

  • Category set to Client
  • Target version set to 2.71rc2

#5 Updated by IR4T4 almost 6 years ago

  • Target version changed from 2.71rc2 to 2.78

#6 Updated by IR4T4 almost 3 years ago

  • Related to Bug #922: Fix timescale div 0 issues added

Also available in: Atom PDF