Bug #260

Alt key in combination with any other key causes the Critical Stop sound

Added by IR4T4 about 6 years ago. Updated over 5 years ago.

Status:Fixed% Done:

100%

Priority:NormalSpent time:-
Assignee:Jacker
Category:Client
Target version:2.71rc2
OS:Windows Arch:

Description

From Ragnar http://www.dev.etlegacy.com/boards/3/topics/343

"Alt key in combination with any other key causes the Critical Stop sound, and sometimes show the windows mouse cursor. I use this key for crouching. Splash for walking. For example, if I press Alt+W to crouch forward, it comes to this problem.

...this only happens when the game is in windowed mode. In the original ET this problem has not occurred.
"

Associated revisions

Revision eccad328
Added by Jacker almost 6 years ago

client: Fixed the issue on windows alt+* keycombinations causing an error message sound, refs #260

History

#1 Updated by IR4T4 about 6 years ago

  • Description updated (diff)

#2 Updated by 100zherBG about 6 years ago

Remark: Some like this happen on the Linux client (not only on the Legacy mod) if my shortcut for keyboard language change is a Alt+Shift. If I press this combination in game my keboard swap to cyrrilyc and game engine repeat last valid pressed key (for example W). Other critical shortcuts for windowed mode is a shortcuts for window menu etc... Currently I use Ctrl for crouching and C for medic needle.

#3 Updated by IR4T4 almost 6 years ago

  • Description updated (diff)

#4 Updated by IR4T4 almost 6 years ago

  • % Done changed from 0 to 10

Can’t reproduce this with current code on my linux PC ... ALT is bound to crouch and ETL is started in windowed mode. No issues. Actually most OS have their own shortcuts and these are active when the game runs in a window and not full screen - the system doesn’t know we don’t want the OS shortcut function executed #-). This is a thingy we can’t fix but a user can. Try to disable OS shortcuts and let us know if the issue still occures.

#5 Updated by Ragnar almost 6 years ago

Were you actually able to reproduce this bug on Windows in the meantime?

#6 Updated by IR4T4 almost 6 years ago

  • Category changed from Client to 2

#7 Updated by Jacker almost 6 years ago

I’ll try this out today, lets see if i find the issue.

#8 Updated by Jacker almost 6 years ago

  • Status changed from New to Feedback
  • Assignee set to Jacker
  • % Done changed from 10 to 100

This should be fixed now, at least i cannot reproduce it anymore after my last commit. Please test it out and if all is OK I will close the bug ticket.

#9 Updated by Ragnar almost 6 years ago

Seems to work, thanks.

#10 Updated by Jacker almost 6 years ago

  • Status changed from Feedback to Fixed

#11 Updated by Radegast over 5 years ago

  • OS set to Windows

Also available in: Atom PDF