Bug #261

Registering URI Scheme Fails

Added by Harlekin about 6 years ago. Updated over 5 years ago.

Status:Fixed% Done:

100%

Priority:LowSpent time:-
Assignee:Radegast
Category:Client
Target version:2.71rc2
OS:Windows Arch:

Description

et://etlegacy.com causes the problem that URI passes "et://etlegacy.com" as IP not only "etlegacy.com". Client trys to conenct to the server IP/DNS: et://etlegacy.com

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\et]
"URL Protocol"=""
@="URL: et://"

[HKEY_CLASSES_ROOT\et\DefaultIcon]
@="C:\\path_to_etl\\etl.exe"

[HKEY_CLASSES_ROOT\et\shell]

[HKEY_CLASSES_ROOT\et\shell\open]

[HKEY_CLASSES_ROOT\et\shell\open\command]
@="C:\\path_to_etl\\etl.exe +set fs_basepath \"C:\\path_to_etl\" +connect \"%1\""

shot0000.jpg (37.4 KB) Harlekin, 22.03.2013 09:42

145

Associated revisions

Revision b573159c
Added by Radegast about 6 years ago

client: ommit et:// in connect command, fixes #261

History

#1 Updated by Radegast about 6 years ago

  • Assignee set to Radegast
  • Target version set to 2.71rc2

#2 Updated by Radegast about 6 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

#3 Updated by Harlekin about 6 years ago

et://et3.hirntot.org:27999 starts now ET but conenct to: et3.hirntot.org:27999/.

See Screenshot

#4 Updated by Radegast about 6 years ago

  • Status changed from Fixed to Feedback

Harlekin, you are saying ET:L connects to the server? What is the problem then?

#5 Updated by Harlekin about 6 years ago

  • % Done changed from 90 to 100

Just wondred about the / after the port. Well looks like it is planed to have it there.

#6 Updated by Radegast about 6 years ago

  • Status changed from Feedback to Fixed

OK. That trailing slash is just passed in the url from your browser. It shouldn’t do any harm.

#7 Updated by Radegast over 5 years ago

  • OS set to Windows

Also available in: Atom PDF