Task #92

Relase 2.70 rc1

Added by IR4T4 over 6 years ago. Updated almost 4 years ago.

Status:Fixed% Done:

100%

Priority:NormalSpent time:1.50 hour
Assignee:Radegast
Category:General
Target version:2.70rc1
OS: Arch:

Description

- finish installer scripts
– add required files to the repo (misc path ?!)

- make sure we do release builds
- Linux: clarify libstdc version for GLIB compatibility ...
- fix icons for Win & Linux

Known issues:
- Linux: on very first start command map in Limbo may show undefined (orange) shaders
- Linux/Win?: omni-bot.cfg isn’t stored in fs_homepath although 'SaveConfigChanges’ is set to 1. (mabye related to relative path setting of omnibot_path ...)


Subtasks

Bug #97: fs_homepath on Windows - use SHGFP_TYPE_CURRENTFixed


Related issues

Blocked by ET: Legacy Development - Task #39: Create a windows installer for the final 2.70 release Fixed 31.05.2012 31.05.2012
Blocked by ET: Legacy Development - Bug #101: Clean up of bg_pmove.c broke Windows build Fixed 03.11.2012

History

#1 Updated by Radegast over 6 years ago

- Linux: clarify libstdc version for GLIB compatibility ...

I don’t know what ideal GLIB version to compile with would be. I’ll try to compile linux binaries on Ubuntu 6.06 LTS. Hopefully, it is ancient enough.

We need to do at least a minimal testing run before we put the binaries on our website. Let’s set up "legacy" server on etlegacy.com:27961 and have a one hour match on Sunday evening, e.g. 17:00-18:00?

#2 Updated by IR4T4 over 6 years ago

I did compile mods in the past on a Debian 5 VM with libstdc 5. But I think version 5 isn’t an option anymore.
From my experience Red Hat always runs after but maybe I’m wrong.

strings /usr/lib/libstdc++.so.6 | grep GLIBCXX

Current Debian Squeeze uses:

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13

On Lenny:

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_FORCE_NEW
GLIBCXX_DEBUG_MESSAGE_LENGTH

On Etch:

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8

Radegast what’t the output on your Ubuntu 6.06 LTS? I also remember libstdc 6 != libstdc 6 ...

#3 Updated by Radegast over 6 years ago

Ubuntu 6.06 LTS:

GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_FORCE_NEW

#4 Updated by Radegast over 6 years ago

Version 2.70rc1 is tagged in git and linux binaries were uploaded to the Files section.

#5 Updated by IR4T4 over 6 years ago

Linux upload has some issues ... I’ve removed it.

#6 Updated by IR4T4 over 6 years ago

  • Subject changed from Relase 2.70 to Relase 2.70 rc1
  • Status changed from New to Fixed

#7 Updated by IR4T4 over 6 years ago

  • Status changed from Fixed to In Progress

#8 Updated by Radegast over 6 years ago

  • Status changed from In Progress to Fixed

Also available in: Atom PDF