Bug #993

Warning: (libjpeg) Unsupported color conversion request

Added by keMoN about 2 years ago. Updated about 2 years ago.

Status:Invalid% Done:

100%

Priority:Low
Assignee:-
Category:Client
Target version:ALL
OS: Arch:

Description

As put in a review on the installer of 2.74 in July 2016, there is a texture/shader bug on CTF Pool.
When started in ET: Legacy 2.75, the title warning appears and the texture is orange/black.

Affected texture is textures/ctf_pool/pool_pow2 and the shader appears fine:

textures/ctf_pool/pool_pow2    
{
    surfaceparm woodsteps
    implicitMap -
}

legacy 2.75.jpg (343 KB) keMoN, 07.02.2017 17:18

pool_hky.jpg (30.9 KB) keMoN, 16.02.2017 09:46

pool_pow2.jpg (30 KB) keMoN, 16.02.2017 09:46

694
706
707

History

#1 Updated by Spyhawk about 2 years ago

  • Category set to General
  • Priority changed from Normal to High
  • Target version set to 2.76

#2 Updated by thunder about 2 years ago

dont think implicitmap does work on renderer2

#3 Updated by keMoN about 2 years ago

Don’t know about that, but the problem above is present with both renderers.

#4 Updated by keMoN about 2 years ago

  • File deleted (vanilla.jpg)

#5 Updated by IR4T4 about 2 years ago

  • % Done changed from 0 to 10

I think this bug is related to pool_hky.jpg and pool_pow2.jpg (see ctf_pool_v2/textures/ctf_pool/) Sizes of images are not power of 2.
We don’t load the image and the orange default shader is used.

#6 Updated by keMoN about 2 years ago

What the hell? Really?
I specifically checked that because I suspected that. Seems like I’m getting old

//EDIT:
No, both textures are good. I’ve attached them.

#7 Updated by keMoN about 2 years ago

  • File pool_hky.jpg added
  • File pool_pow2.jpg added

#8 Updated by IR4T4 about 2 years ago

  • % Done changed from 10 to 20

I’ve had a closer look at this. There are other similar textures used in this pk3 and these are displayed. Both images are bugged - there are color issues and libjpeg is correct. My image preview shows other colors than real image viewers/editors. (Preview is correct)

#9 Updated by keMoN about 2 years ago

  • File deleted (pool_hky.jpg)

#10 Updated by keMoN about 2 years ago

  • File deleted (pool_pow2.jpg)

#11 Updated by keMoN about 2 years ago

  • % Done changed from 20 to 40

I should really have suspected that problem, when even the title gives you the hint of "color conversion". Meh.

The faulty images are in CMYK color mode. ET: Legacy supports only RGB colors.
I have transformed the two and attached them. However, there is nothing that we can really do, since it’s a custom map.

I don’t know if it is possible to support CMYK mode, but this would be the only thing we could do.
Normally, you just don’t use that mode though, so I’m not entirely sure if it’s needed.

#12 Updated by keMoN about 2 years ago

#13 Updated by IR4T4 about 2 years ago

  • Category changed from General to Client
  • Status changed from New to Invalid
  • Target version changed from 2.76 to ALL
  • % Done changed from 40 to 100

#14 Updated by IR4T4 about 2 years ago

  • Priority changed from High to Low

#15 Updated by keMoN about 2 years ago

Any info on this IR4?

#16 Updated by IR4T4 about 2 years ago

There is no reason beside this buggy image to support a subtractive color system.
"The CMYK color system is the color system used for printing."

Also available in: Atom PDF